Cannot specify device when activation vpn

Выкатили молодцы добрые свеженький networkmanager 1.12.0 с кучей полезных фич, обрадовались все, да как начали наливать обновушку, да как начали включать VPN и VPN говорит: Cannot specify device when activation vpn

Примерный лог:

checking for LIBSECRET... yes
checking for LIBNM_GTK... no
configure: error: Package requirements (libnm-gtk >= 1.2.0) were not met:

Package ’NetworkManager’, required by ’libnm-gtk’, not found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables LIBNM_GTK_CFLAGS
and LIBNM_GTK_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Нууу, хорошо, мы не гордые, придется ждать обновления модулей для NM, а пока откатимся до предыдущей версии.

wget https://archive.archlinux.org/packages/n/networkmanager/networkmanager-1.10.8-1-x86_64.pkg.tar.xz
sudo pacman -U networkmanager-1.10.8-1-x86_64.pkg.tar.xz
systemctl restart NetworkManager

Если, вдруг, пропадет данный архив из репы Арча, залил пакет к себе: https://mirror.margent.ru/networkmanager-1.10.8-1-x86_64.pkg.tar.xz

и VPN снова работает.

P.S., дата выхода патча не известно, разработчики Gnome ничего толком не говорят.

Поделиться
Отправить
Запинить
2018   antergos   arch   linux   manjaro   networkmanager   openvpn   vpn